1. Issues With 117 HD Plugin  - 12-20-2022 #1

    Offline
    Junior Member
    13
    43
    Dec 2022
    #
    my pc is way more than capable of handling it but for some reason it drops my fps to like 14... i have to run the client of gpu to run smoothly i would like to play on hd? has anyone else experienced this and or found a solution?
    Last edited by Shade; 12-20-2022 at 02:57 PM.

    Quote  

  2. Offline
    Junior Member
    5
    261
    Oct 2022
    #
    What specs does your PC have? My older i7 4th gen device struggled. Since upgrading to i7 12th gen it's been good as gold.

    Quote  

  3. Offline
    Junior Member
    13
    43
    Dec 2022
    #
    i have a 10700k i have no issues on the plug in on osrs just here :/

    Quote  

  4. Offline
    Junior Member
    3
    1
    Oct 2022
    #
    Definitely should run it fine. Might be worth trying a clean reinstall?

    Quote  

  5. Offline
    Administrator
    Administrator
    1,286
    2378
    Apr 2020
    #
    The Battlescape client if more heavy for your PC to run over OSRS, some people are just generally unable to run the 117 HD Plugin due to this with their older hardware, however there are a few methods that can be tested prior to calling it a loss;

    - Close all clients,
    - Load up a fresh client (only 1)
    - Toggle the 117 HD Plugin On/Off a few times (unless it works at first)
    - Leave it toggled on, and refresh your client, this should be good to go.


    Quote  

  6. Offline
    Retired
    1,430
    1438
    Sep 2009
    #
    Zombies Supporter!
    10 Year Veteran
    Make sure to run BattleScape.exe with your GPU. Intel HD Graphics sucks with the plugin.




    Quote  

  7. Offline
    Junior Member
    13
    43
    Dec 2022
    #
    how do i ensure its running with that? i changed it to gpu in the client but i cant do hd and gpu?

    Quote  

  8. Offline
    Retired
    1,430
    1438
    Sep 2009
    #
    Zombies Supporter!
    10 Year Veteran
    Quote Originally Posted by Shade View Post
    how do i ensure its running with that? i changed it to gpu in the client but i cant do hd and gpu?
    If you have an NVIDIA Card, you would open up NVIDIA Control Panel -> Manage 3D Settings -> Global Settings -> Set default to use GPU and not Onboard Graphics -> Program Settings -> Add BattleScape.exe -> Set to use Global Settings





    Quote  
Reply to Thread
Results 1 to 8 of 8